设为首页收藏本站

益盟操盘手论坛

 找回密码
 5秒钟注册

用新浪微博连接

一步搞定

只需一步,快速开始

查看: 76485|回复: 1359

史上最牛MACD指标公式源码

  [复制链接]

该用户从未签到

发表于 2012-2-5 11:36 | 显示全部楼层 |阅读模式
史上最牛MACD指标公式,绝对值得推荐给各位。如果觉得不错,还希望大家能够回个帖子支持一下!

公式源代码如下:
DIFF:EMA(CLOSE,6)-EMA(CLOSE,16),ColorFFFF26;
DEA:EMA(DIFF,5),Color8A15FF;
MACD:=2*(DIFF-DEA);
对DIFF :0-(EMA(CLOSE,6) - EMA(CLOSE,16));
对DEA :0-(EMA(DIFF,5));
对称 : 0-(2*(DIFF-DEA)),STICK,ColorFF6060,LINETHICK1;
{D1:EMA(C,16)-EMA(C,6),Color26FF26;
E2:EMA(D1,5),ColorFF1EFF;};
STICKLINE(MACD>=0,MACD,0,4,1),COLORF00FF0;
STICKLINE(MACD<0,MACD,0,4,1),colorwhite;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,10,0 ),Color00C4C4;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,6.3,0 ),Color00EAEA;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2.2,0 ),Color0BFFFF;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,1.65,0 ),Color46FFFF;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,8 ,0 ),Color0000BB;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,6.3 ,0 ),Color0000F0;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2.2,0 ),Color1111FF;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1.65 ,0 ),Color3535FF;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,10,0 ),Color9B009B;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,6.3 ,0 ),ColorCA00CA;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2.2,0 ),ColorF000F0;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1.65,0 ),ColorFF28FF;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,8,0 ),Color00AA00;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,6.3 ,0 ),Color00CE00;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,2.2,0 ),Color00F700;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1.65 ,0 ),Color2DFF2D;
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
STICKLINE(低位金叉,0,-0.18,10,0),ColorE8E8E8;
STICKLINE(低位金叉,0,-0.18,4,0),ColorF2F2F2;
STICKLINE(低位金叉,0,-0.18,2,0),ColorFFFFFF;
DRAWTEXT(低位金叉,-0.2,' 金叉'),ColorFFFFFF;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,0,-0.18,10,0),Color0042CC;
STICKLINE(二次金叉,0,-0.18,8,0),Color004FF2;
STICKLINE(二次金叉,0,-0.18,8,0),Color3375FF;
DRAWTEXT(二次金叉,-0.2,' 金叉二'),Color3375FF;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
STICKLINE(底背离,0,0.13,10,0),ColorCECE00;
STICKLINE(底背离,0,0.13,4,0),ColorFFFF00;
STICKLINE(底背离,0,0.13,2,0),ColorFFFF44;
DRAWLINE(A1=0,DEA,底背离,DEA,0),ColorFFFFFF,linethick1;
DRAWTEXT(底背离,0.3,' 底背离'),ColorFFFF26;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
DRAWLINE(A2=0,DEA,顶背离,DEA,0),colorgreen,linethick1;
游客,如果您要查看本帖隐藏内容请回复

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?5秒钟注册

x

评分

9

查看全部评分

  • TA的每日心情
    开心
    2016-5-25 06:18
  • 签到天数: 1 天

    [LV.1]初来乍到

    发表于 2016-5-25 06:29 | 显示全部楼层
    感谢楼主,参考学习中
    回复 支持 1 反对 2

    使用道具 举报

  • TA的每日心情
    开心
    2018-1-22 00:52
  • 签到天数: 497 天

    [LV.9]以坛为家II

    发表于 2012-2-5 17:38 | 显示全部楼层
    回复 支持 2 反对 0

    使用道具 举报

    该用户从未签到

    发表于 2012-2-5 17:16 | 显示全部楼层
    提示: 作者被禁止或删除 内容自动屏蔽
    回复 支持 2 反对 0

    使用道具 举报

  • TA的每日心情
    奋斗
    2018-1-19 13:15
  • 签到天数: 554 天

    [LV.9]以坛为家II

    发表于 2012-2-5 14:44 | 显示全部楼层
    回复 支持 2 反对 0

    使用道具 举报

  • TA的每日心情
    奋斗
    2016-6-29 09:15
  • 签到天数: 38 天

    [LV.5]常住居民I

    发表于 2016-5-25 00:04 | 显示全部楼层
    谢谢分享好材料,看看里面的内容
    回复 支持 1 反对 1

    使用道具 举报

    该用户从未签到

    发表于 2012-2-5 20:22 | 显示全部楼层
    ddddddddddddddd
    回复 支持 1 反对 0

    使用道具 举报

    该用户从未签到

    发表于 2012-2-5 18:38 | 显示全部楼层
    谢谢楼主分享
    回复 支持 1 反对 0

    使用道具 举报

    该用户从未签到

    发表于 2012-2-5 20:41 | 显示全部楼层
    谢谢,学习研究一下。
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2012-2-5 21:06 | 显示全部楼层
    能说下使用方法和市场意义吗?
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2012-2-5 21:10 | 显示全部楼层
    dddddddddddddd
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2012-2-5 22:05 | 显示全部楼层
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2012-2-5 23:11 | 显示全部楼层
    支持~~~
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2012-2-5 23:14 | 显示全部楼层
    em180857 发表于 2012-2-5 21:06
    能说下使用方法和市场意义吗?


    能说下使用方法和市场意义吗?
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2012-2-5 23:50 | 显示全部楼层
                  
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2012-2-6 03:56 | 显示全部楼层
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2012-2-6 05:21 | 显示全部楼层
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2012-2-6 09:09 | 显示全部楼层
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2012-2-6 09:13 | 显示全部楼层
    对称有何妙用???
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    发表于 2012-2-6 10:07 | 显示全部楼层
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    奋斗
    2017-12-14 00:00
  • 签到天数: 370 天

    [LV.9]以坛为家II

    发表于 2012-2-6 10:13 | 显示全部楼层
    DDDDDDDDDDDDD

    评分

    1

    查看全部评分

    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    开心
    2018-1-21 11:14
  • 签到天数: 184 天

    [LV.7]常住居民III

    发表于 2012-2-6 10:39 | 显示全部楼层
    谢谢分享
    回复 支持 反对

    使用道具 举报

    您需要登录后才可以回帖 登录 | 5秒钟注册

    本版积分规则

    中国操盘手|手机版|小黑屋|Archiver|隐私保密协议|百度地图|益盟操盘手    

    GMT+8, 2018-1-22 10:43 , Processed in 0.034923 second(s), 12 queries , Redis On.

    Powered by Discuz! X3.2

    © 2001-2013 Comsenz Inc.

    快速回复 返回顶部 返回列表