设为首页收藏本站

益盟操盘手论坛

 找回密码
 5秒钟注册

用新浪微博连接

一步搞定

只需一步,快速开始

查看: 1533|回复: 2

请高手修改虚拟成交量公式 让公式在小周期可用

[复制链接]

该用户从未签到

发表于 2017-7-27 17:20 | 显示全部楼层 |阅读模式
这是益盟软件的虚拟成交量公式,但是这个公式在小周期显示时失真。不能象通达信那样,小周期也可以显示。现在附上益盟和通达信的源码,请老师给综合在一起。
    今日:VOL,pRECIS0,VOLSTICK;


MA5:MA(VOL,5),pRECIS0;

MA10:MA(VOL,10),pRECIS0;

MA120:MA(VOL,120),pRECIS0;

倍量:(VOL/REF(VOL,1)>2 AND COUNT(CLOSE>OPEN,1)) OR (LOW>REF(HIGH,1) AND COUNT(OPEN>CLOSE,1) AND VOL/REF(VOL,1)>2),pRECIS0,COLORFF00FF;

stickline(倍量,0,v,7,0),COLORFF00FF;

百日地量:LLV(VOL,100)=VOL,COLORwhite,pRECIS0;

stickline(百日地量,0,v,7,0),COLORwhite,pRECIS0;

三十地量:LLV(VOL,30)=VOL,pRECIS0,COLORFFDE00;

stickline(三十地量,0,v,7,0),COLOR003300;

倍缩量:VOL/REF(VOL,1)<0.5,COLORyellow,pRECIS0;

stickline(倍缩量,0,v,7,0),COLORyellow;

缩量涨:COUNT(C>REF(C,1),2)=2 AND COUNT(VOL<REF(VOL,1),2)=2,pRECIS0,COLORgreen;

stickline(缩量涨,0,v,7,0),COLORgreen;

黑阳: IF(LOW>REF(HIGH,1) AND COUNT(OPEN>CLOSE,1),0.5,0),pRECIS0,COLORBLUE;

stickline(黑阳,0,v,7,0),COLORBLUE;

红阳:IF(LOW>REF(HIGH,1) AND COUNT(OPEN<CLOSE,1),0.5,0),pRECIS0,COLORRED;

stickline(红阳,0,v,7,0),COLORRED
VOL:VOL#VOLUMN;
LASBAR:=BARSTATUS==2;
VOLX:IF(LASBAR,DYNAINFO(17)*DYNAINFO(38),0),linethick0;
STICKLINE(LASBAR,0,VOLX,7.5,1),COLORYELLOW,layer7;


通达信的虚拟成交量也可以在小周期显示。

TOTAL:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,TOTALFZNUM,1)))));
MTIME:=MOD(FROMOPEN,TOTAL);
CTIME:=IF(MTIME<0.5,TOTAL,MTIME);
VVOL:IF((CURRBARSCOUNT=1 AND DYNAINFO(8)>1),VOL*TOTAL/CTIME,DRAWNULL),NODRAW;
STICKLINE((CURRBARSCOUNT=1 AND DYNAINFO(8)>1),VVOL,0,-1,-1),COLOR00C0C0;
VOLUME:VOL,VOLSTICK;
MAVOL5:MA(VOLUME,5);
MAVOL30:MA(VOLUME,30);
MAVOL120:MA(VOLUME,120);

该用户从未签到

发表于 2017-7-28 16:27 | 显示全部楼层
这可能与益盟软件有关系吧?一些函数通达信有的,益盟没有。
回复 支持 反对

使用道具 举报

  • TA的每日心情

    2017-9-28 20:46
  • 签到天数: 3 天

    [LV.2]偶尔看看I

    发表于 2017-9-18 13:29 | 显示全部楼层
    数值倒是有挺多额,看你用的是啥版本的吧?
    回复 支持 反对

    使用道具 举报

    您需要登录后才可以回帖 登录 | 5秒钟注册

    本版积分规则

    中国操盘手|手机版|小黑屋|Archiver|隐私保密协议|百度地图|益盟操盘手    

    GMT+8, 2018-9-22 01:23 , Processed in 0.021293 second(s), 10 queries , Redis On.

    Powered by Discuz! X3.2

    © 2001-2013 Comsenz Inc.

    快速回复 返回顶部 返回列表