设为首页收藏本站

益盟操盘手论坛

 找回密码
 5秒钟注册

用新浪微博连接

一步搞定

只需一步,快速开始

查看: 4870|回复: 8

[实战兵法] 最强的主图划线公式源码奉献

[复制链接]

该用户从未签到

发表于 2017-5-5 14:52 | 显示全部楼层 |阅读模式
划线:=ZIG(1,3);
最低价转向:=ZIG(2,3);
DRAWTEXT(划线>REF(划线,1) AND 划线>REF(划线,-1) ,1.01*H,H),COLORFF00FF;
DRAWTEXT(最低价转向<REF(最低价转向,1) AND 最低价转向<REF(最低价转向,-1) ,0.99*L,L),COLORGREEN;
A1:=REF(HIGH,3)=HHV(HIGH,2*6+1);
B1:=FILTER(A1,3);
C1:=BACKSET(B1,3+1);
D1:=FILTER(C1,3+1);
A2:=REF(LOW,3)=LLV(LOW,2*6+1);
B2:=FILTER(A2,3+1);
C2:=BACKSET(B2,3+1);
D2:=FILTER(C2,3);
E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2;
E2:=(HIGH+LOW)/2;
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR barstatus=2 OR BARSCOUNT(CLOSE)=1;
L1:=(D2 AND NOT(D1 AND E1<E2));
H2:=D1 AND NOT(D2 AND E1>=E2);
X1:=REF(BARSLAST(H1),1)+1;
F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));
G1:=F1>REF(F1,1);
I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1);
L2:=LD OR barstatus=2 OR BARSCOUNT(CLOSE)=1;
X2:=REF(BARSLAST(L2),1)+1;
F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));
G2:=F2>REF(F2,1);
I2:=BACKSET(G2,2);
HD:=I2>REF(I2,1);
DRAWLINE(LD,L,HD,H,0),COLORWHITE;
DRAWLINE(HD,H,LD,L,0),COLORWHITE;
J1:=BACKSET(barstatus=2 ,MIN(BARSLAST(HD),BARSLAST(LD))+1);
J2:=J1>REF(J1,1);
DRAWLINE(J2,IF(HD,H,L),barstatus=2 ,IF(BARSLAST(HD)>BARSLAST(LD),H,L),0),COLORWHITE;
C点:=BARSLAST(LD);
DRAWTEXT(LD AND BARSLAST(HD)<BARSLAST(ref(ld,1)) ,L*0.995,'A'),COLORRED;
DRAWTEXT(HD,H*1.005,'B'),COLORYELLOW;

该用户从未签到

 楼主| 发表于 2017-5-5 15:01 | 显示全部楼层
{:1_201:}{:1_201:}{:1_201:}{:1_201:}
回复 支持 反对

使用道具 举报

  • TA的每日心情
    慵懒
    2017-7-26 22:53
  • 签到天数: 2 天

    [LV.1]初来乍到

    发表于 2017-5-19 10:18 | 显示全部楼层
    谢谢楼主分享,祝你股市长红,财源滚滚!
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    开心
    2018-6-21 08:58
  • 签到天数: 691 天

    [LV.9]以坛为家II

    发表于 2017-7-2 09:38 | 显示全部楼层

    谢谢分享!!!!!谢谢分享!!!!!!!!!!!!!!!!!!!!
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    开心
    2018-6-21 08:58
  • 签到天数: 691 天

    [LV.9]以坛为家II

    发表于 2017-7-2 09:39 | 显示全部楼层

    谢谢分享!!!!!谢谢分享!!!!!!!!!!!!!!!!!!!!
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    开心
    2018-6-21 08:58
  • 签到天数: 691 天

    [LV.9]以坛为家II

    发表于 2017-7-2 09:39 | 显示全部楼层

    谢谢分享!!!!!谢谢分享!!!!!!!!!!!!!!!!!!!!
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    开心
    2018-6-21 08:58
  • 签到天数: 691 天

    [LV.9]以坛为家II

    发表于 2017-7-2 09:40 | 显示全部楼层

    谢谢分享!!!!!谢谢分享!!!!!!!!!!!!!!!!!!!!
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    开心
    2017-12-12 08:51
  • 签到天数: 30 天

    [LV.5]常住居民I

    发表于 2017-11-13 08:04 来自手机 | 显示全部楼层
    为什么总是说我验证码回答错误
    回复 支持 反对

    使用道具 举报

    您需要登录后才可以回帖 登录 | 5秒钟注册

    本版积分规则

    中国操盘手|手机版|小黑屋|Archiver|隐私保密协议|百度地图|益盟操盘手    

    GMT+8, 2018-6-21 23:51 , Processed in 0.023807 second(s), 10 queries , Redis On.

    Powered by Discuz! X3.2

    © 2001-2013 Comsenz Inc.

    快速回复 返回顶部 返回列表